Jump to content
Sign in to follow this  
rahmansunbeam

PGSQL Enterpise GDB connection error

Recommended Posts

Did anyone face this error? 

rhu1x5.png

I am repeatedly facing this while connecting ArcGIS Desktop to PostgreSQL. I installed the PostgreSQL with apt-get inside an Ubuntu vm. The vm also has Enterprise 10.5.1 installed and configured. The plan is to configure the Portal once this connection is done. 

I have already tried copying the ST_GEOMETRY file (*.so) for v9.5 (/usr/lib/postgresql/9.5/lib) but that didn't work. Also tried 9.4 and 9.6. Tried both desktop and server files. -_-

Edited by rahmansunbeam

Share this post


Link to post
Share on other sites

Oh, the flashbacks... This is one of the factors that pushed me to QGIS.

Anyway, you have to download correct ST_Geometry library from ESRI site. Thing is - ESRI lags behind PostgreSQL versions. So you can't use the latest or even second latest PGSQL.

https://pro.arcgis.com/en/pro-app/help/data/databases/add-the-st-geometry-type-to-a-postgresql-database.htm

EDIT: Most important question - what version of PGSQL do you have and has ESRI explicitly announced their support for it?

Edited by jorrarro
Forgot to ask about PG version
  • Like 1

Share this post


Link to post
Share on other sites

The ubuntu apt-get channel currently installs 9.5 version, which I already mentioned. I tried the PGSQL 9.4 as well, with the downloaded files from 'my esri', still no response. Should I try 9.3 as well? 9.3 is still supported (minimum requirement page) for 10.5.1 but not for the 10.6. 

Update (26 Jan): three days already passed since I asked for a fix and ESRI South Asia couldn't respond. Meanwhile I compiled the exact version of PGSQL (9.5.3) from source, still no luck. <_<

Update (31 Jan): They asked me for a teamviewer session which I happily participated. They said, they will 'recreate the linux version of this error and let me know'. I hope they have a linux expert in Singapore or send this to someone at USA. People in ESRI Southasia region - beware. :wacko:

Update (5 Feb): I can't believe they are still 'researching and looking for the solve'. By this time I installed Desktop 10.6 and able to solve this with same file from 10.6's folder. I am not saying anything to these 'engineers'. 

Edited by rahmansunbeam
secretly solved

Share this post


Link to post
Share on other sites

Update (7 Feb): Finally I requested to close the issue, after suggesting the solve to them (which was suppose to the other way around). B) 

I hope they note this issue carefully and flag this issue as a bug. I could have done this myself if I'd know how. I am also surprised they didn't immediately have a solution, pokes back and forth once in everyday after lunch (though they immediately asked me if I want to close this issue once I suggested the solve !!).  

Wish me luck...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.