Jump to content
Sign in to follow this  
darksabersan

PostgreSQL and ArcCatalog 10.1 configuration

Recommended Posts

Hi guys,

I need your help to configure PostgreSQL and ArcCatalog.
First, the technical details about my installation:
Based on Windows Se7en x64
I've installed PostgreSQL 9.0.18 as Geo Database in order to use QGIS 2.4.0 and all was fine.
Why PostgreSQL 9.0.5? Just simply because I have ArcGIS Desktop 10.1 and I put the Client Libraries 9.0.5 inside "C:\Program Files (x86)\ArcGIS\Desktop10.1\bin"
Now, when I want to connect in ArcCatalog then the problem appear (even with localhost as Instance info).

 

axikxw.jpg

 

I know that is possible to do so even without ArcSDE.

All comments and helps are welcome!

 

darksabersan.

Share this post


Link to post
Share on other sites

please explain in english the sentences after FATAL, it looks like in france ;)

have you try to check the postgresql log for this error? maybe you will find interesting clue

Share this post


Link to post
Share on other sites

please explain in english the sentences after FATAL, it looks like in france ;)

have you try to check the postgresql log for this error? maybe you will find interesting clue

[FATAL: the databaseSQL state: ]

Where is the postgreSQL log file? I am completely new with it.

Share this post


Link to post
Share on other sites

Hi adnan0001,

 

Thank you for your SQLServer Connection Tutorial, but I'm looking more specifically for PosgreSQL.

Until now, I didn't found something to solve my issue.

 

darksabersan.

Share this post


Link to post
Share on other sites
darksabersan, you need first to licensed your version  of  arcsde otherwise arcatalog wont connect through porstgresql..

While you get the license you need to enable the geodb feature in arccatalog, by inserting the location of the license file with extension .ecp

Share this post


Link to post
Share on other sites

I think darksabersan not asked anything related to Esri Enterprise Geodatabase which is in fact refer to ArcSDE, he probably likes to configure the following thing:

http://www.esri.com/library/whitepapers/pdfs/how-to-set-up-geoportal-server-122.pdf

 

interesting notes are below:

http://northredoubt.com/n/2013/08/22/postgresqlpostgis-and-arcgis-arcmap-10-2/

  • Like 2

Share this post


Link to post
Share on other sites

Hi guys,

I need your help to configure PostgreSQL and ArcCatalog.

First, the technical details about my installation:

Based on Windows Se7en x64

I've installed PostgreSQL 9.0.18 as Geo Database in order to use QGIS 2.4.0 and all was fine.

Why PostgreSQL 9.0.5? Just simply because I have ArcGIS Desktop 10.1 and I put the Client Libraries 9.0.5 inside "C:\Program Files (x86)\ArcGIS\Desktop10.1\bin"

Now, when I want to connect in ArcCatalog then the problem appear (even with localhost as Instance info).

 

axikxw.jpg

 

I know that is possible to do so even without ArcSDE.

All comments and helps are welcome!

 

darksabersan.

Try to write following in Instance: localhost,5432

Hope it will work. In my PC it works.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you adnan0001 for your video, bdsmolla for the interesting links and infinity007 for the trick.

Finally it works.

Instance: localhost,5432  (was the solution)

And It is also really important to take care about the naming convention. I mean no capital or mixed letters (Upper and Lower).

axikxw.jpg

i.e:

My_Database

MY_DATABASE

but:

my_database

 

;)

 

darksabersan.

  • Like 1

Share this post


Link to post
Share on other sites

You are most welcome..

If possible try to make a short video for installation of postgre sql n configuration of it n how ti connect it at enterprise level..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.